Mark's Nimbus 197 T Cup

rSilva

Paid Member
... Too much silicone has been used to fit the cover which is now rock hard and broken away and gone through the oil galleries and cams!
...
If it's on the feed lines for the lifters is guaranteed that the bottom end also got some. It all comes from the same supply, the oil pump.
 

Mark_L

Platinum Member
Been a while since any updates on this so here's a small one.

I bought a spare engine with low compression on no. 1 cylinder. Which has now been stripped. Put through the hot wash and ultrasonic and painted.

IMG_20190508_184232.jpg


The Block is at the machine shop and the parts to rebuild the bottom end have been ordered and got a new set of core plugs already.

The Block is getting a hone and the face checked, the crank is being polished and the head is getting a minimal skim to make sure it is flat.

So it's getting, Pec Rods and wossner 8.5:1 pistons, all new bearings thrusts, water pump cam belt kit etc.

Looking forward to driving it again.
 

Big Ben

Winner - POTM February 2018
Paid Member
Low compression pistons ready for big boost eh?!!

Super tech valves and new lifters as well Mark? Look forward to seeing it done
 

Mark_L

Platinum Member
Low compression pistons ready for big boost eh?!!

Super tech valves and new lifters as well Mark? Look forward to seeing it done
Not Really Ben, just keeping it safe as the cost of the pistons is the same.

No valves at the moment. Maybe a set of catcams springs. Budget isn't allowing for too much! Getting the R26 box rebuilt too whilst I'm doing it!
 

Mark_L

Platinum Member
So 1 step forward 2 steps backwards!

The catcams springs arrived.

Went to gap the rings and there's something wrong. The ring gaps are the wrong way around. 2nd ring has the gap I need for the top ring and vise versa.

Top ring in brown. IMG_20190603_191243.jpg
 

Mark_L

Platinum Member
So a few more bits,
IMG_20190605_183106.jpg
I managed to fit the crank tonight,
Still waiting on some rings which is starting to drive me mad as I'm getting impatient.
IMG_20190606_193125.jpg
I did try an old top ring which had done over a 100k which was still tighter than the new one's. Always happens to me!!
 

Jesse James

Platinum Member
Really can't wait to see this running mate. Keeps those updates coming, cause I am looking forward to seeing the old girl again

Sent from my SM-G960F using Tapatalk
 
  • Like
Reactions: Mark_L

Mark_L

Platinum Member
Really can't wait to see this running mate. Keeps those updates coming, cause I am looking forward to seeing the old girl again

Sent from my SM-G960F using Tapatalk
Will do Jesse, had planned to when I first got it up and running but it was short lived!
 

Mark_L

Platinum Member
So tonight I lapped in all the valves, took a few hours as the exhaust ones really needed it!
IMG_20190610_195057.jpg IMG_20190610_195127.jpg IMG_20190610_182907.jpg


I also got this today,

IMG_20190610_122028.jpg


And my intercooler core will be with me tomorrow.

Unfortunately still no rings!! Should have them Wednesday! I hope!
 

Similar Thread Suggestions