Lewis's RB Clio 197

Discussion in 'Projects/Progress Threads' started by lewishunter98, Aug 17, 2018.

  1. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Sean197 likes this.

  2. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Couple photos from Goodwood Hot hatch Sunday and a pic of some coilovers I picked up yesterday too! 0aca3fbecc69286fd38a1b52f7981623.jpg 131182df20320e4ea73fb06c873ae6ee.jpg e25a267d9e39052d3f24f022cccaa36b.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Sean197 and Beany like this.
  3. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Not much has happened recently. Got some parts ready to go on come pay day, (B14'S, tie rods, track rod ends, rack bush etc.) Should feel like a new car I hope.

    But was a bit bored today so decided to dewiper the Clio. Looks so much more clean! Well happy with it acd6acf67f7c199ae219a0f13f164a68.jpg 82170a648456ce5ced3ef188e4c10c15.jpg f6c2a9ae107b0fe61eed01f1e856ab69.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Foxspeed, Big Ben and Beany like this.
  4. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Got the car back today from it going in the garage yesterday

    List of parts changed:

    - B14'S
    - Steering Rack bush
    - Inner tie rods
    - track rod ends (cup racer ones I found for a steal)
    - Powerflex bushes that were pressed into spare control arms

    Went for an alignment at the alignment centre as well.

    IMG]http://i66.tinypic.com/zml5eb.jpg[/IMG

    Mechanic had a couple issues when swapping everything over hence why I picked it up today! Both pinch bolts on the hubs snapped, as did the OSF shock when taking the nut off. Spring flew off and nearly caught him in the face!

    Car feels absolutely transformed now though and sits a little better at the back. Really firm but so planted in the corners (tested on my private racetrack)

    As you can tell the alignment was savagely out after all the changes haahaa! c82c2a68e00e599b30b092c22705a739.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
    wootwoot, Micah, Sean197 and 3 others like this.
  5. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Beany likes this.
  6. Big Ben

    Big Ben Winner - POTM February 2018 Paid Member

    Messages:
    5,463
    Location:
    Herts
    Car:
    197
    Bet that feels better now!!!

    Time to get it on a proper racetrack:thumb:
     
    Pav and lewishunter98 like this.
  7. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    10x better! It was pulling all over the shop previously.

    I know, I'm absolutely dying to get it on track, next year for sure I'm doing some track days.

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Big Ben and Beany like this.
  8. Beany

    Beany Platinum Member

    Messages:
    2,101
    Location:
    Doncaster
    Car:
    RB 200 cup
    Well we’re always doing plenty so tag along one time
     
    Pav and lewishunter98 like this.
  9. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Yeah I really want to mate,

    Just wanted all these issues ironing out before going round

    Just been out in it now and it still took me by surprise when I first hit a bump The powerflex bushes are definitely noticeable!

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Beany and Big Ben like this.
  10. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    listen to the boys above..they talk sense :sunglasses:
     
    lewishunter98 and Beany like this.
  11. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Hahaha! I'm listening don't worry^

    Also managed a good deal on a 200 diffuser today! Things are happening way quicker with this car than I ever intended.

    Not the best picture but was limited to daylight and you can't not take photos when a mod is done 693c0c670ee77b4a7e245683a80b4b71.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Addison, Big Ben and Beany like this.
  12. Beany

    Beany Platinum Member

    Messages:
    2,101
    Location:
    Doncaster
    Car:
    RB 200 cup
    Sad point but that reg is very similar to my old twingo (ma08 uyz)

    It’s looking good and rather clean.... I’m jealous
     
    lewishunter98 likes this.
  13. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Haha no way! That's pretty cool. When I had my C2 which was YS56 XZD, someone else got one the same spec as mine that was like YS56 XZA or something along the lines and I couldn't believe how close they were!

    Thanks man but it's far from being actually clean at the moment, hasn't been washed in about a month :worried:

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Beany likes this.
  14. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Had a ktec decat pipe fitted today, as well as a noise sorted from the rear since having the B14'S fitted! So I went for a drive, despite the weather being awful it's the most fun I've had in the car for months. Got some pics and it's really dirty now. Hasn't been washed since before hot hatch Sunday so it's a fair while!

    Oh and the decat sounds so good! Seems to rev a little more freely now, and it feels like it pulls a lot harder above 5k (might just be in my head?) 42cb4a4310b466cadfcda0caf1d23eee.jpg db5af7b0d1ecdd3d5fec31a4cb77eb94.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Sean197, Rallye-nick and Big Ben like this.
  15. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    :thumb::thumb:
     
    lewishunter98 likes this.
  16. Rallye-nick

    Rallye-nick Winner - POTM September 2018 Paid Member

    Messages:
    28
    Location:
    West sussex
    Car:
    2006 Clio 197
    Cars looking lovely! Are you local to Goodwood? I’m only 10 minutes from Goodwood would be good to get a local mini meet together there one weekend when the weather improves
     
    lewishunter98 likes this.
  17. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Thanks mate! Yeah kinda! I'm based in Hythe/Southampton. Takes about an hour to get there. Was just down that way last weekend to swap diffusers with someone actually.

    But yeah! There's loads of us in the area mate, have a group chat of about 10 of us based in the Southampton/new forest area on Facebook

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Rallye-nick likes this.
  18. Rallye-nick

    Rallye-nick Winner - POTM September 2018 Paid Member

    Messages:
    28
    Location:
    West sussex
    Car:
    2006 Clio 197
    Ah cool, well once I’ve got my car back on the road next year i will try and pop along to a meet or two with you guys
     
    lewishunter98 likes this.
  19. lewishunter98

    lewishunter98 Paid Member

    Messages:
    519
    Location:
    Southampton
    Car:
    Racing Blue Clio 197
    Gave the car a much needed clean and coat of fusso yesterday and went for a bit of a drive

    Took my front spacers off recently as the car still feel like it's pulling side to side over cambered roads and under braking but it feels as if it's still there! More so at high speeds, yesterday it felt as if the front just wasn't connected with the wheel when I went over a rough patch in the road at 70/80 ish? I'm at a loss as to what it could be. Going to get my alignment checked before anything but it just doesn't feel right. Anyway. Pics.

    If anyone knows what my issue might be please drop your suggestions I can't seem to find any play anywhere 089f572eb492392d332d2d68cd3fd07f.jpg 4cde30aafd34019d4681cc7e8e3add40.jpg 601190e854214072327a6cd306095b13.jpg

    Sent from my ONEPLUS A5010 using Tapatalk
     
  20. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.