Google Chrome

cliovirgin

Gold Member
I can’t access this site from my PC.
This site can’t provide a secure connection.
www.clio197.net uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_
MISMATCH
The client and sever don’t support a common SSL protocol version or cipher suite. This is likely to be caused when the sever needs RC4, which is no longer considered secure.
Any ideas ?
 

turkie172

Paid Member
On win7 IE11 I'm getting "only secured content is displayed" and a button that I can press to show all content
 

Jimmy

Good cop
Administrator
There have been some recent changeovers to a secure SSL https site, so this may be the root of some of the issues you are seeing. Nik has very kindly been sorting all this out, and did suggest there may be one or two small issues.
 

Nik

Administrator
All working fine in Chrome and other browsers for me.

Screenshot 2018-10-09 at 16.18.13.png

It's probably a caching issue, where your browser is using content stored on your PC that is linking to the http version rather than https. If you clear all browser cache for this site it should work fine.
 
  • Like
Reactions: Jimmy

Nik

Administrator
Ahh ok, it looks like you are using Windows XP. The latest versions of Chrome on XP don't support the recent SSL certificate standards, which will give you that error. The error about RC4 and the website having an outdated security code is a red herring, it's actually a newer code than your computers operating system supports.

XP is well out of support so you will have issues like this. I'm surprised you can get some other HTTPS sites to load tbh. I've read that you might have more luck using Firefox web browser as it has its own cryptographic support rather than using the one in Windows.
 
  • Like
Reactions: cliovirgin

cliovirgin

Gold Member
Ahh ok, it looks like you are using Windows XP. The latest versions of Chrome on XP don't support the recent SSL certificate standards, which will give you that error. The error about RC4 and the website having an outdated security code is a red herring, it's actually a newer code than your computers operating system supports.

XP is well out of support so you will have issues like this. I'm surprised you can get some other HTTPS sites to load tbh. I've read that you might have more luck using Firefox web browser as it has its own cryptographic support rather than using the one in Windows.
Quite correct with Windows XP, but professional version. I have no problems entering any other https sites including Clio Sport !