My first RS197

Discussion in 'Projects/Progress Threads' started by adam thomas, Dec 28, 2017.

  1. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Always wanted one of them but in all honesty at the moment I can't really afford one lol

    Sent from my LYA-L09 using Tapatalk
     

  2. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    what Ben said or get a r26 if you dont want to meg your...
     
    adam thomas likes this.
  3. ToiletDuck

    ToiletDuck Paid Member

    Messages:
    26
    Car:
    Ultra Red Meglio 197
    He wants to Meg the Clio, he's just scared :tearsofjoy:
     
    Pav likes this.
  4. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Shut up lol
    Sent from my LYA-L09 using Tapatalk
     
  5. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    well what a great day yesterday was despite the weather !

    headed up to Anglesey for a track day and was greeted with torrential rain and hail !
    car was awesome though and the uniroyal rainsport3's helped a lot !

    as always here are a few pictures and some in car footage

    46304818182_06c7eacff3_k.jpg 2018-12-17_04-26-06 by adam thomas, on Flickr
    44538753060_f85d3cddd7_k.jpg 2018-12-17_04-18-45 by adam thomas, on Flickr
    46355578081_122de4d4ee_k.jpg 2018-12-17_04-34-23 by adam thomas, on Flickr
    46355578511_804855eedf_k.jpg 2018-12-17_04-35-43 by adam thomas, on Flickr

     
  6. rcwsr

    rcwsr Paid Member

    Messages:
    106
    Location:
    East Midlands
    Car:
    Clio RS 200
    Car and photos look amazing. Where's the yellow rs badge from, or is it painted?
     
    adam thomas likes this.
  7. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Thank you. Its a sticker from a girl on the 197/200 Facebook page called steph Foster
    Sent from my LYA-L09 using Tapatalk
     
  8. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Not been on here much lately. Still considering selling the clio

    Currently have a few problems that I need to fix before I can decide what I'm doing. Atm I have a knock coming from the steering and I think it's the rack so I have a new Bush insert for inside the rack to fit

    Also having a problem with my radiator fan coming in even when the car is cold?

    And obviously I have a 3rd gear crunch but who doesn't have that

    Anyway as much as its being a pain in the bum I cleaned it

    a8cba9671eadb9a352202298868cb071.jpg

    Sent from my LYA-L09 using Tapatalk
     
    Big Ben likes this.
  9. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    sparkling that is...hope you manage to sort all the niggles out...
     
  10. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Cheers mate I'm sure I will in good time. Have already grabbed a new steering rack for it

    Sent from my LYA-L09 using Tapatalk
     
    Pav likes this.
  11. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Found the source of my intermittent fan issue. Nice easy fix though

    Also went and picked up a rensport splitter and fitted, looks so much better but the car is disgusting at the minute and I have zero motivation to clean it in this weather 6f347884f2b9e875e4f8b007c06345fa.jpg 9d9ca18e5303bb57bb424c8ff07bd6be.jpg 6c3943c9a23590ee06d290c51917d082.jpg d0a3c90fbbdffe1ce8bca1c719d409af.jpg

    Sent from my LYA-L09 using Tapatalk
     
    suj and Big Ben like this.
  12. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    glad to got to the bottom of it...one less thing to worry about..
     
  13. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Always nice when it's simple too

    Sent from my LYA-L09 using Tapatalk
     
  14. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Couldn't have the car looking as dirty as it did. So a quick wash was in. Order this morning looks much better and I can actually see in my mirrors and out the back Now 3718012adf09f9105e1458507f6dad86.jpg

    Sent from my LYA-L09 using Tapatalk
     
  15. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Cooling fan issues again. Fan seems to come on as soon as I put the ignition on. I have changed the temp sensor and the resistor but its still happening. Next step is to change the fan and thermostat. Anyone had any of the same problems and does anyone know where the relay is for the fan?

    Cheers

    Sent from my LYA-L09 using Tapatalk
     
  16. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Another day spent on the car trying to sort this fan issue. Ordered a new thermostat in the week just incase it was that.

    So today I've changed the fan itself.
    Changed the thermostat.
    Checked all wiring for visual damage (didn't find any)
    And fitted my stud and nut conversion

    Thermostat fell apart as I took it out so was a good job I ordered one

    So far so good. Ran the car 3 times today so far and the fan hasn't come on fingers crossed it doesn't c5477e06d8fc8a7f00712ff38b871485.jpg 41f4e94212b4485887c55c14dbec912b.jpg cdb28dfae39538f0e2de3bc233bfa72d.jpg

    Sent from my LYA-L09 using Tapatalk
     
  17. Pav

    Pav Moderator

    Messages:
    11,611
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    hope all your troubles are sorted now..fingers crossed...
     
  18. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    I spoke to soon

    Sent from my LYA-L09 using Tapatalk
     
  19. suj

    suj Paid Member

    Messages:
    755
    Location:
    Birmingham / Warwick
    Car:
    Nimbus Grey 197
    Oh no, what happened Adam?

    Also my thermostat did the same (TWICE!) I literally couldn't work out how, original was genuine, second was a good brand too, one in now is genuine but has been fine (touchwood).
     
  20. adam thomas

    adam thomas Gold Member

    Messages:
    287
    Location:
    Birmingham
    Car:
    Clio 197
    Still coming on for no reason. Starting to think they're is a wiring problem somewhere

    Sent from my LYA-L09 using Tapatalk
     

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.