2006 Deep Black weekend warrior. Clubsport money pit!

Helpimonfire

Paid Member
So my bank holiday Monday was spent on the turd as expected.

New Brembo HC discs up front as the old ones were glazed as fook. Also had some scoring too, the DS Uno pads were low on material but I reckon they could go again in a pinch.

Decided to give PBS ProRace pads a go up front with their ProTrack offerings on the rear, initial impressions are good, they feel like they have better bite than the DS Uno, also fitted some new droplinks as the old ones (Meyle HD) were a tad knocky and I hadn't realised it, but all fittings were odd sizes. I had to use everything from a 15mm to an 18mm to get them off :tearsofjoy:

Took the car out to bed the pads and discs in, seemed decent so far but I never braked in anger, just consistent heat and the occasional harder push on the pedal.

Came back home and about a mile from home I had a strange buzzing noise from behind the dash, no idea what it was as it went away as I slowed down. I'll take the car out again tomorrow and see what was causing it if it does it again.
 

Helpimonfire

Paid Member
As many of you have probably learned from this thread, I'm an absolute liability when I have money after the bills have all been paid for the month. It's an unhealthy thing and I fucking love it :sweatsmile: :oops:

First purchase of the weekend was a set of Yellowspeed coilovers. Complete with track spring rates because it's barely on the road anymore so it doesn't need to be comfortable.

Secondly I found someone local with a tyre rack they were willing to part with for sensible money.IMG_20210905_184608.jpg

Once again... It's been expensive :tearsofjoy:
 

Helpimonfire

Paid Member
IMG_20210909_172305.jpg
IMG_20210909_172258.jpg

Finally got all my tyres swapped across the rims, MRFs on the Wizards, Kuhmo V70a on the Suzukas and Eagle F1 on my Rotas. Taken the slicks off as I don't have the balls to run them yet :tearsofjoy: :sweatsmile:

Loaded up ready for a sprint day on Saturday, got my YSR Coilovers yesterday but I don't have the time to fit them and set them up. That's Sundays job!
 

RSRowe

Paid Member
Bet it’ll be close. I’m sure mine does about 24ish on a good run

Tyres aren’t hanging in the wind on our trailer though.
 

Helpimonfire

Paid Member
Bet it’ll be close. I’m sure mine does about 24ish on a good run

Tyres aren’t hanging in the wind on our trailer though.
Yeah I wanted a lower rack but with the hydraulic tilt and the winch, I couldn't fit the low profile one. Nevermind! :sweatsmile:
 

Helpimonfire

Paid Member
It's difficult to compare them to the DS Uno pads after today because they never really got up to the same temperatures as running for 45 minutes at Snetterton. First impressions are that they're decent for a wallet friendly pad. I'll be able to tell you more at the end of October when I go to Bedford, then Snetterton in the space of 5 days, then potentially Donny a week later.

Curborough sprint with RSUK...

Good day today, didn't do many runs as it was mega busy and we turned up later than planned due to struggling to peel the bed off my back :sweatsmile:
Started the day on the Kuhmo V70s which are a hard compound, ideal for hammering around a big track for long sessions, not ideal for a short sprint circuit when cold... Felt the rear let go and went into a tank slapper, missing a built up mound somehow and ended up facing the wrong way. Had to style it out with a (poorly executed) handbrake turn and finished off my lap:tearsofjoy:

Swapped over to the MRFs and ran a personal best time, previous was a 1:34.9, todays was a 1:32.51. Chuffed with that.

I did have a decent start to a run only for the brake pedal to hit the floor at the end of the straight, came in to investigate but couldn't find anything, ended up going out again and had no issues. Think I need to bleed the ABS pump again, I'm not convinced I got all the air out before.

The Autec Wizards were a great buy, they suit the Clio perfectly!
Video of a lap coming soon when I can be bothered to upload it to the YouTubes.

(Trying to upload some photos and it's not working. Technical difficulties...)
 
  • Like
Reactions: Big Ben

tcw

Paid Member
It's difficult to compare them to the DS Uno pads after today because they never really got up to the same temperatures as running for 45 minutes at Snetterton. First impressions are that they're decent for a wallet friendly pad. I'll be able to tell you more at the end of October when I go to Bedford, then Snetterton in the space of 5 days, then potentially Donny a week later.

Curborough sprint with RSUK...

Good day today, didn't do many runs as it was mega busy and we turned up later than planned due to struggling to peel the bed off my back :sweatsmile:
Started the day on the Kuhmo V70s which are a hard compound, ideal for hammering around a big track for long sessions, not ideal for a short sprint circuit when cold... Felt the rear let go and went into a tank slapper, missing a built up mound somehow and ended up facing the wrong way. Had to style it out with a (poorly executed) handbrake turn and finished off my lap:tearsofjoy:

Swapped over to the MRFs and ran a personal best time, previous was a 1:34.9, todays was a 1:32.51. Chuffed with that.

I did have a decent start to a run only for the brake pedal to hit the floor at the end of the straight, came in to investigate but couldn't find anything, ended up going out again and had no issues. Think I need to bleed the ABS pump again, I'm not convinced I got all the air out before.

The Autec Wizards were a great buy, they suit the Clio perfectly!
Video of a lap coming soon when I can be bothered to upload it to the YouTubes.

(Trying to upload some photos and it's not working. Technical difficulties...)
for the money I might give them a punt, my last set of performance friction 08 completely disintegrated.

If it’s remotely helpful, I have CLIP and am based not a million miles away in Chelmsford if you need to bleed the ABS pump that way I’m sure we can sort something.
 

Helpimonfire

Paid Member
Progress!IMG_20210912_173106.jpgIMG_20210912_173120.jpgIMG_20210912_173124.jpg

Yellowspeed coilovers are on. Still need setting up properly but I've got a reasonable ride height set, I know they'll settle a little but we're off to a good start. Camber is nearly maxed out on the top mounts and looks around 3ish degrees? Possibly more but they're equal now.

Massive thanks to @suj for writing a brilliant guide on how to fit the YSR Coilovers, hopefully he'll post it up on the forum for others to use since these are now more common among the Clio massive. Also a shout-out to @DS197 for selling me his track spec YSRs so I didn't have to wait a month for them to arrive.

Currently waiting to get booked in for a full geo setup with corner weighting at a local company who ran a Clio Cup car a few years back. Fingers crossed it'll be done before the next outing!