Toyosport knocking

Discussion in 'Engine, Gearbox, Exhaust and Air Intake' started by Kent197, Nov 7, 2018.

  1. Kent197

    Kent197 Paid Member

    Messages:
    114
    Car:
    Clio RS200
    I have read as many previous threads as I can and understand that the toyosport knocks once fitted - supposedly due to engine movement worn mounts.

    I fitted a toyo mainifold and soon as I drove it it knocked when put throttle down.

    Just fitted upper and lower power flex mounts, I’m sure they work, because even when I start the engine now, I know it is pretty damn tight in there, also got the vibrations etc which I can deal with.

    Although it STILL knocks ? :worried:

    Any other ideas / experiences on this?
     

  2. lewishunter98

    lewishunter98 Paid Member

    Messages:
    217
    Car:
    Racing Blue Clio 197
    To be fair I have seen some people say they have had the subframe notched as well as mounts but not many. Usually just the mounts solve it

    I don't know if it's worth maybe trying the gearbox one too?

    Sent from my ONEPLUS A5010 using Tapatalk
     
  3. Kent197

    Kent197 Paid Member

    Messages:
    114
    Car:
    Clio RS200
    Thanks will look into it.

    Can I drive it as intended?
     
  4. lewishunter98

    lewishunter98 Paid Member

    Messages:
    217
    Car:
    Racing Blue Clio 197
    Shouldn't have any issues driving it I don't think! Just more of an annoyance than anything else

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Kent197 likes this.
  5. Kent197

    Kent197 Paid Member

    Messages:
    114
    Car:
    Clio RS200
    This noise is intense, very loud and jarring, hope someone has a fix, will try dog bone mount as said above, but I’m sure my engine does not move now so I’m at a loss
     
  6. lewishunter98

    lewishunter98 Paid Member

    Messages:
    217
    Car:
    Racing Blue Clio 197
    Did you say you've done torque mount and dog bone already?

    Sent from my ONEPLUS A5010 using Tapatalk
     
  7. turkie172

    turkie172 Paid Member

    Messages:
    831
    Location:
    N. Ireland
    Car:
    197
    It will not be the engine moving as much as it will be the angle you have it at to begin with slacken the bottom mount and the top torque mount pulling the top of the engine forward should lift the manifold up from the sub frame if that's what the knocking is then tighten the top to hold it there and then the bottom see how that goes. You would amazed how much vibration and noise can come from the torque arm if there is slack in it or not tightened properly.
     
  8. Kent197

    Kent197 Paid Member

    Messages:
    114
    Car:
    Clio RS200
    Thanks thought it may be along them lines, the noise is not “sinister” I don’t think but it is LOUD and jarring, tainting the 200 experience.

    Will get it on some lifts next week, will post an update.

    @lewishunter98 I have done lower and upper torque mounts so far.
     
    lewishunter98 likes this.
  9. lewishunter98

    lewishunter98 Paid Member

    Messages:
    217
    Car:
    Racing Blue Clio 197
    Right okay, was just confused as you said about the dogbone but you've already done it so nevermind I know what you mean about knocking sounds though. My ktec exhaust hits my rear beam and it's so loud and annoying

    Sent from my ONEPLUS A5010 using Tapatalk
     
    Kent197 likes this.

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.