Whining on cold start

Hi needs some assistance with a whining noise which has recently started happening on my car on cold start, goes quite once warm and gets slightly louder when I push down the clutch, belts have all been done less than 500miles a go, would I be correct to assume this is a clutch release bearing issue? Any assistance or anyone who has had the same issue would be helpful,

cheers
 

Big Ben

Winner - POTM February 2018
Paid Member
If you could post a recording of the noise might help people identify it better?
Alternator on mine made a whining noise. Quite common
 
Interestingly enough it’s stopped doing it to the point where you cannot hear it with a phone, the only time it gets noticeable louder is when the clutch is fully pressed. Just looking at ways to rule out so I don’t end up replacing parts for the sake of it. Would having the clutch fully engaged cause a change in the noise of the alternator??
 

Big Ben

Winner - POTM February 2018
Paid Member
Interestingly enough it’s stopped doing it to the point where you cannot hear it with a phone, the only time it gets noticeable louder is when the clutch is fully pressed. Just looking at ways to rule out so I don’t end up replacing parts for the sake of it. Would having the clutch fully engaged cause a change in the noise of the alternator??
Regarding the clutch that’s beyond my mechanical knowledge sadly! Someone else might know
My alternator was worse when cold for some reason. Not talking massive noise but when it’s your own vehicle you notice these things