UR 197 F1 Team R27 - Progress Thread

Discussion in 'Projects/Progress Threads' started by Deer_Dodger, Aug 18, 2017.

  1. matt9566

    matt9566 Paid Member

    667
    Barnsley
    Ultra Red R27 #91
    They certainly aren't, i'd love to put them on mine as they were deleted at factory by the original owner but I can't justify the cost!

    Haha, you should definitely have them.. as they say, you're only as young as you feel!
     
    Deer_Dodger likes this.

  2. sevenfourate

    sevenfourate Devotee of OCD Paid Member

    Lowestoft, England.
    Racing Blue RS-200
    Brilliant start to a progress thread. Got some lovely bits on an already lovely car right quick.....

    One in particular :sunglasses:

    Looking forward to watching your progress. You're clearly passionate and loving it !!!
     
    Deer_Dodger likes this.
  3. LOCKE

    LOCKE Paid Member

    Glasgow
    RB 182 Cup/LY 197 R27
    I'm 44 and get slated as a boy racer because I own 2 Clio Sports. If only they knew what we knew?
     
    Jimmy and Deer_Dodger like this.
  4. Deer_Dodger

    Deer_Dodger Paid Member

    191
    I agree, the driving experience they provide belies their humble shopping car origins and age.

    Their electrics seem a little bit wobbly. The below are what seems to be somewhat common personality traits that were present when I got it;

    Horn

    I fixed the horn, eventually after removing the front end and buying a new squib, only to find it was a bent contact in the old squib. This fix came courtesy of Heppy997.

    Speed 4 on the heater fan

    Forum to the rescue again, the usual connector issue of a partially melted plug. Checked the pollen filter, like new. Found the usual plug had partially melted around one pin, crimped up the connector around this pin and it worked.........for a month or so, since gone again and yet to put my head under the dash again.

    Driver’s door ‘push to lock’ button

    Forum assistance again, squirted WD40 into button. My door now locks, brilliant.

    Inconsistent power delivery, uneven running and stalling when cold

    Have a guess, forum sorted again. Crawled underneath the car, removed TDC sensor (plus half my skin on my hand), cleaned with WD40, replaced and car now starts, never stalls and delivers power consistently.

    In summary, quite a few minor faults, but with the aid of a well managed and supported forum, all fixed, for FREE. However, having a car with push button start and what appears to be flakey electrics does worry me slightly. Can they be bump started?
     
    ///M and Big Ben like this.
  5. l33th3tr33

    l33th3tr33 Paid Member

    They clearly do, look at the price hike in the past 2 years!!!


    Sent from my iPhone using Tapatalk Pro
     
  6. Pav

    Pav Moderator

    Manchester
    albi blue 197 with boost
    nice..keep them coming..:french:
     
  7. Jimmy

    Jimmy Good cop Administrator

    Thanks for your kind words about the forum! That's absolutely our goal - to help out owners of these cars as much as possible, and provide a friendly community as well :smile:

    I'm not certain about the bump starting question, however from what I can remember there haven't been any issues with the starter button failing....
     
    Pav and Deer_Dodger like this.
  8. Deer_Dodger

    Deer_Dodger Paid Member

    191
    Out with the old

    ecf35f250c7f47d2be6165a66080e67c.jpg

    In with the new

    a4235d43245f74b0bd1e8fbec536af13.jpg

    e68bc9dc2c36bd1ec1e826745d91ee07.jpg


    Sent from my iPhone using Tapatalk Pro
     
    Jimmy and sevenfourate like this.
  9. Deer_Dodger

    Deer_Dodger Paid Member

    191
    There just arrived too, I didn’t realise the rear were progressively wound too. Should introduce some nice compliance pottering around prior to firming up when needed.

    1129e6835edf104a09cf96a37111244f.jpg
     
    Benno and sevenfourate like this.
  10. sevenfourate

    sevenfourate Devotee of OCD Paid Member

    Lowestoft, England.
    Racing Blue RS-200

    Looks great - cheers for the pics :smile: Looks like it fitted perfect :sunglasses:

    You're missing a grey rubber washer on the top of the plunger.. My garage "lost" mine when i had the belts etc done. Luckily got one from a car being broken.

    Pics of it 3 or 4 posts down here:

    http://www.clio197.net/threads/197-...t-group-buy-mk3-post-221-page-12.54807/page-4

    You'll LOVE the Springs too. Great choice.....
     
  11. Pav

    Pav Moderator

    Manchester
    albi blue 197 with boost
    hope you enjoy the new firmer ride...
     
  12. Deer_Dodger

    Deer_Dodger Paid Member

    191
    I see it, I’ll try and track one down, thanks for the heads up


    Sent from my iPhone using Tapatalk Pro
     
    sevenfourate likes this.
  13. Deer_Dodger

    Deer_Dodger Paid Member

    191
    I’m considering replacing the whole lower wishbones or adding Powerflex to my current ones. Anyone had any experience with poly bushed suspension? I don’t want excessive noise or vibration if that helps steer replies.

    Thanks

    John


    Sent from my iPhone using Tapatalk Pro
     
  14. Deer_Dodger

    Deer_Dodger Paid Member

    191
    Just bought these from l33th3tr33

    Can't wait to fit them. I know they're probably heavier than my silver reflectors, but oh do they look so much better, IMHO anyway. I know we all like different things, so I hope I haven't offended reflector lovers ;-)

    These will probably be my only visible modification, but still OEM, so keeps me happy. 41825a71b19440e815966e97227e4133.jpg 88af2e2accd5433996129c7f7f62f636.jpg

    Sent from my E6553 using Tapatalk
     
    sevenfourate and ///M like this.
  15. Deer_Dodger

    Deer_Dodger Paid Member

    191
    I can't drive the forum :-( managed to reply to my own post!

    Sent from my E6553 using Tapatalk
     
    sevenfourate likes this.
  16. Pav

    Pav Moderator

    Manchester
    albi blue 197 with boost
    they look miles better..should be one of the 1st mods on these..:thumb:
     
  17. Deer_Dodger

    Deer_Dodger Paid Member

    191
    Just ordered my Royal Steering Wheel retrim in the following spec;

    Full Dark grey Alcantara 9002
    Red top stripe
    Light Silver 412 stitching

    Photos to follow once it arrives.

    Will endeavour not to kill myself with the airbag during change over. Even with the battery disconnected, airbags scare the heck out of me.



    Sent from my E6553 using Tapatalk
     
    sevenfourate likes this.
  18. Benno

    Benno Gold Member

    @Deer_Dodger with the TDC Sensor issue, were you finding that the car would stall/nearly stall in reverse? Mine's doing that and I need to practically ride the clutch sometimes to keep it running! Hasn't done it recently but cut out a few times on a cold start but would start fine 2nd push of the button... Going to try the WD40 push button thing too!

    My Eibachs are sat in the boot next to the H&R spacers waiting to go on..! How much was your steering wheel out of interest? Just sent off an enquiry form to them yesterday!
     
  19. Deer_Dodger

    Deer_Dodger Paid Member

    191
    Mine would stall when cold only, but would still sometimes hunt when warm.

    When it stalled, it would sometimes not restart for 10-15 minutes.

    I'm guessing if yours is in a worse condition than mine, it could well stall even when warm if the revs drop low enough.

    The WD40 was for my dodgy 'push to lock' button in my door handle.

    I did also cure my TDC sensor by cleaning it and covering the connector block with WD40.

    I think there may be a pattern emerging with my mechanical expertise. If if can be cured by squinting a can of WD40 on it, I'm stuffed!

    The wheel cost me £155 plus a £100 deposit, refundable when you return your wheel and I have to pay for the return postage. I've had one of their wheels before and the workmanship is like OEM, just better. I'll post some hi res photos when it arrives.

    Sent from my E6553 using Tapatalk
     
    Benno likes this.
  20. Benno

    Benno Gold Member

    Haha should have made that a bit clearer, I meant the door handle button, not the push to start button lol.

    Any forward gear, mine's fine after warming up. Occasionally it will hunt a tad at cold but tends to be okay. Doesn't like reverse though at all, strange. Never had an issue restarting though, will have a good look at it anyway when I get a chance.

    I've never seen their work in person, but the amount of people on here and other sites recommending Royal is incredible. My wheel is peeling badly now so time to go.
     

  • Share This Page