Dodgy trackrod end?

Discussion in 'Suspension, Brakes & Steering' started by littleg78, Jul 4, 2019.

  1. littleg78

    littleg78 Paid Member

    Messages:
    18
    Location:
    Essex
    Car:
    2012 Renault Clio RS 200
    I thought my steering was a bit odd - following camber of road both ways - so had my wheel allignment checked and found this!!!



    The guys tightened it up, but a few weeks after and I'm getting that same weird steering feel again, so assuming it's loose again?!?

    Booked in for a new trackrod end which will hopefully fix once and for all. Anyone seen anything like this before?
     

  2. RSRowe

    RSRowe Paid Member

    Messages:
    173
    Car:
    Clio 197
    There's a little metal top hot which goes on the trackrod. Yours appears to be missing
     
    littleg78 likes this.
  3. littleg78

    littleg78 Paid Member

    Messages:
    18
    Location:
    Essex
    Car:
    2012 Renault Clio RS 200
    Thanks for looking! I've been googling images of track rods but not come up with anything like you describe.

    If I have a new track rod end fitted, I'm guessing the missing piece will be replaced... or is there something else I should be asking for at the same time?

    This is the only problem with the car so fingers crossed it will be an easy and inexpensive fix!!!
     
  4. Andyyox

    Andyyox Paid Member

    Messages:
    15
    Car:
    197
    The top hat often comes out still attached to the old track rod. Then people don't put it onto the new one. They don't come included with new track rods.
     
    littleg78 likes this.
  5. Andyyox

    Andyyox Paid Member

    Messages:
    15
    Car:
    197
    littleg78 likes this.
  6. turkie172

    turkie172 Paid Member

    Messages:
    970
    Location:
    N. Ireland
    Car:
    197
  7. littleg78

    littleg78 Paid Member

    Messages:
    18
    Location:
    Essex
    Car:
    2012 Renault Clio RS 200
    Thanks for the link to the old thread - that explains perfectly why it's loosened off twice now.

    I happily pay the £20 to make the problem go away! I searched ebay, but couldn't find the right thing... probably using the wrong search terms - could you post a link please?

    Thanks!!!
     
  8. littleg78

    littleg78 Paid Member

    Messages:
    18
    Location:
    Essex
    Car:
    2012 Renault Clio RS 200
    Thanks - you read my mind with the link!

    I've ordered from eBay because I need asap!

    Thank you everyone for your help!!!
     
    lewishunter98 likes this.
  9. littleg78

    littleg78 Paid Member

    Messages:
    18
    Location:
    Essex
    Car:
    2012 Renault Clio RS 200
    The new metal top hat arrived in the post this morning, and was fitted along with a new trackrod end this afternoon - all working as it should now!

    Thanks again to everyone who commented - I hate to think how much this would have cost if I'd put the car into a main dealer!
     
    Andyyox, Big Ben and Foxspeed like this.
  10. RSRowe

    RSRowe Paid Member

    Messages:
    173
    Car:
    Clio 197
    That was quick!

    I believe it's a new hub assembly at the dealers. Dread to think what that price is :tearsofjoy:
     
    littleg78 likes this.
  11. VolumeX

    VolumeX

    Messages:
    724
    Car:
    Clio mk3 197 & 200 20th
    Sorted proper. Plenty of good tech heads on here to come to the rescue!
     

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.