Smoke From Steering Wheel Help

Discussion in 'Clio General Chat' started by Lewis1988, Jul 23, 2017.

  1. Lewis1988

    Lewis1988

    Messages:
    2
    Car:
    Renault Clio 1.4 Tourer
    Hi all, not a sport but just a regular 2011 clio tourer but thought I'd ask for advice. I was driving home last night and out of nowhere, smoke started pouring from the steering wheel. I got out and switched the engine off. I turned it on a minute later to limp the final mile home and had no more smoke.

    This morning I've removed the wiper stalk module from the steering column and inside its all melted. Before I took it out, it all worked except the control to engage with washer jets. The wipers worked, the audio controls all worked too which is promising.

    I've ordered a replacement part, no other damage seems obvious. I just started the car without the wiper stalk module and there's no visible faults. The only issue now is that while the part is removed, my lights stalk doesnt work at all. Am I right in thinking the 2 stalks are connected by a wiring loom?

    Video here:


    Thanks in advance.
     

  2. Yiannis197

    Yiannis197 Paid Member

    Messages:
    3,633
    Location:
    London
    Car:
    Clio R27
    Yes there are connected and I presume that if one is out then it makes the other one redundant.
     
  3. Antti O

    Antti O Paid Member

    Messages:
    1,425
    Location:
    Mikkeli, Finland
    Car:
    Clio 197 Ultra red 2007
    Wow, that was quite horrible. I hope that stalk was only part damaged.
    Keep us updated was it fixed with new stalk.
     
  4. Lewis1988

    Lewis1988

    Messages:
    2
    Car:
    Renault Clio 1.4 Tourer
    Hi guys, got a replacement dirt cheap from a scrap clio today. Actually in amazing condition, not a mark on it and no signs of any issues inside. I've fitted the part and everything works absolutely fine. Disaster avoided! Cheers

    Lewis

     
    sevenfourate likes this.
  5. sevenfourate

    sevenfourate Devotee of OCD Paid Member

    Messages:
    8,377
    Location:
    Lowestoft, England.
    Car:
    Racing Blue RS-200 / Citroen C2 GT
    Lucky boy !!!

    "Congrats" and well done you............ :smile:
     
  6. Antti O

    Antti O Paid Member

    Messages:
    1,425
    Location:
    Mikkeli, Finland
    Car:
    Clio 197 Ultra red 2007
    Good to hear it was solved :smile:
     
  7. ClioAsh

    ClioAsh Paid Member

    Messages:
    10
    Car:
    Clio 197
    Does anyone know the correct part number for these modules?
     
  8. Pav

    Pav Moderator

    Messages:
    11,121
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    happened to me not long ago..got a replacement from ebay for £25 delivered..
     
  9. Pav

    Pav Moderator

    Messages:
    11,121
    Location:
    Manchester
    Car:
    albi blue 197 with boost
    has this been fixed??
     
  10. ClioAsh

    ClioAsh Paid Member

    Messages:
    10
    Car:
    Clio 197
    No, my fault is intermittent.
     

  • Share This Page


    1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
      By continuing to use this site, you are consenting to our use of cookies.